Amazon

Friday, February 8, 2008

Rails 2.0, Scaffolding 1.x

Despite having tried to stay completely within Rails 2.0, I miss the dynamic scaffolding 1.x provided. So this is how I got it back.

script/plugin install scaffolding
script/plugin install svn://errtheblog.com/svn/plugins/classic_pagination


The reason I had to install the classic_pagination plugin is because the dynamic scaffolding plugin depends on it.

It all works well, except I am noticing that whenever I dynamically scaffold something, I had to restart my mongrel server in order for it to take, which is a bit odd. I don't recall it working that way in 1.x. But, it will do for now.

No comments: