Amazon

Wednesday, November 7, 2007

Getting Freeciv 2.1.0 to work on Leopard

Reader "j" commented that he is unable to get Freeciv 2.1.0 to run on Leopard. I concur. There is an issue. Until I get around to address it, here's a workaround.

First of all, if you haven't yet done so, run the Freeciv application, set your options as you like it, and click Run Freeciv. An xterm window will open, but not much else.

Then, click on the xterm window to bring it to the foreground, and execute the following command:

~/Library/Application\ Support/Freeciv/2.1.0/run-freeciv.py

This should launch the actual game client. This workaround is working on my 24" iMac running Leopard, and sound support is functional.

Let me know how it turns out for you.

1 comment:

robot_kid said...

That fix works for me - Thanks!

It seems lots of people are having issues with the new launchd-based X11 in Leopard. I hope it's not too difficult to fix up the Freeciv launcher!

-robot_kid